Lasercut 5.3 driver problem MCP6515 - DLL VERSION DOES NOT MATCH FIRMWARE VERSION


#1

Hi guys.

Ive just bought a 2nd hand HPC1290 and Im having some problems. It didn’t come with the software but it DID come with the dongle. I have been trying to get my laptop and Lasercut to talk to each other but ive had no success.

I have downloaded lasercut online and installed it but i get a message saying DLL VERSION DOES NOT MATCH FIRMWARE VERSION on my laser control panel…I have followed some guides and it tells me that my DLL is 4.3.0.0 and my firmware is 4.1.3.0 but i don’t know how to get them to match.

Can anyone please tell me how to solve this problem asap please.

Thank you in advance if I can get any help


#4

Hi mate thank you very much for that.

Should I uninstall lasercut and do then start with a fresh install of this one??


#5

it does not like to be install on top of old one and cannot not be removed from the uninstall built in windows so delete the original directory and re install that’s how I did it and works fine I have 2 just add laser and works on both it an old version that seem to work on them all give it a go sorted my problem out and directed other there as well and sorted their out to if it nont work let us all know dominic may have another idea if it hardware Is it on window 10 PC if so read dominic thread on window 10 it a different problem but may sort your if the software doesnt


#6

No its on windows 7. I’m going to try it on Windows 10 in the morning on my other laptop.

I know it might be a little stupid but could you give me a step by step guide to installing it properly or do you have a UK number that I can call tomorrow do you could walk me through it please.

You’ve be a great help so far so thank you already for that.


#8

Hi John.

Thank you so much.

I just putting a fresh install of windows 7 on now but I’ll give you a call around 10 if that’s ok.


#10

No worries at all John.

I have tried it and it works an absolute treat!!! That you so much you are a life saver!!!

Need to buy you a pint sometime to say thank you!


#11

Scratch that… it works ok but now runs off the edge of the bed as if it doesn’t know how big the bed is… it’s set up for 1200x900 in worktable and the datum works fine??? I’ll ring you at 12 if that’s ok mate


#12

This post was flagged by the community and is temporarily hidden.


#13

Hello

The DLL version does not match firmware version can be a serious issue however and I’ve seen controllers not recover from that issue. Make sure you are using software provided by HPC and NOT the software linked by @JBxrayman on the Nottingham Hackspace website.

The best place to get your files for a HPC is either through HPC laser or you can try this link below:

Let me know how you get on. The links provided by @JBxrayman was not written by me or anyone working with JAS or Smoke & Mirrors. It was created by the Nottingham Hackspace and links to files specific to their laser cutter, setup and firmware and might not be especially useful for you.

You can find help on installation of drivers for Leetro MP6515 here but this is specifically aimed at GWeike machines sold by Just Add Sharks and NOT for Laserscript machines sold by HPC laser:

Let me know how you get on. Windows 7 should be fairly easy and you can find instructions here:

However do NOT use the associated software. It’s not correct for a HPC.

I’ve found that Windows 10 and it’s constant updates and lasercut5.3 don’t make great bedfellows but it does work adequately. But once you have the software communicating with the laser cutter you should be fine.

It might be helpful to ensure you run the software compatibility wizard also for Lasercut5.3 and it’s associated drivers.

The DLL version does not match firmware version can be a serious issue however and I’ve seen controllers not recover from that issue.

I have removed some of @JBxrayman posts to ensure that no-one else tries to use the wrong files for their cutter. Sorry John.

Kindest regards

Dominic Morrow
Smoke & Mirrors


#14

work on the just laser stuff ine and I think it works for him to


#15

Hi John

It sounds like the drivers are working, but the working area for the cutter, motor settings and other essential differences are not working.

The information you provided was helpful, but generally incorrect and the link was NOT created by me or Smoke & Mirrors and isn’t the right place to get software for for a HPC laserscript laser or even a Just Add Sharks machine.

Thanks for the help, but I deleted the posts because they aren’t helpful for future people to find.

Dominic


#16

Hi all.

It worked fine thank you. I just had to chance the pulse unit in machine settings and it’s working fine now!


#17

glad its sorted now to sort my jumping motor


#18

Good to know. Thanks @JBxrayman & @HPC1290 pleased you got sorted, but now with the right link it should be easier for the next person.

Dominic