Identify this laser cutter ...if you can!

So my friends school has this machine and it hasn’t worked…I’m not too sure on the details of it not working until I can get a physical look.
See image below.

I was wondering if anyone know if it runs off the laser cut 5.3 software?

I did a bit of googling but I think it’s a Chinese made machine with leetro controller and a 50w tube.

Any insight would be great. I’m hoping to just install the software on their laptop and magically go tadaaaa as if I did something really clever
Thanks in advance.


Hi Alex,

From the model number it appears to be this (NC 3050)

Point number 7 from the blurb:
“7, Transmit files directly from Corel draw and Auto CAD, Photoshop, etc.”
So, if it is working, you may not need to do much at all!!!

I’ll do a bit more trawling and see if I can find a manual!


A photo of the control pad and the controller would be most useful here.

1 Like

A different model by the same company:
" Graphic format supported: BMP, PLT, DST, DXF, AI

Software supported: TAJIMA, CorelDraw, Photoshop, AutoCAD"

(TAJIMA seems to be some kind of automated embroidery software!)

So it looks like you can just fire DXF files straight at it.

I’d imagine it just needs to be installed as a printer and you simply ‘print’ the DXF to it?

Here are some contact details, you could email them with the model number and ask if they have the driver software available for download?
There seems to be nothing on the website:

Jinan Robotec Machinery Co., Ltd.
Address: No. 88, West Huizhan Rd., High-Tech Zone, Jinan, Shandong, China
Tel: +86-531-68657576
Fax: +86-531-68657576
Mobile: +8615562612576

Thank you very much for the information.
Greatly appreciated.
I will update if it works. :slight_smile:

@phillw @Smokey
Thank you all for the help so far. I have been to tinker with the machine attached to the laser and I’m probably out my depth now as I’m not really a software kind of girl but I know a bit to get by…
I’ve attached some photos of the controller and the pad.
So basically I’ve managed to get the machine to be read by my computer but I cannot download the .mol file to update the configuration or the firmware on the machine. It’s saying that it is an invalid config.
I haven’t managed to connect it to the pc it was connected to as it doesn’t recognise it is attached (school admin accounts eh) so I’m not sure that if I do this step I can use their software called RDworks and just downloaded a new config if you get me.

I’m hoping if I can get past that step then it should work (?)
Any help would be appreciated…or is it a case of getting a new controller and just replacing it.
Images on Imgur


1 Like

Hi @Alexdubarrygurr

That’s a Leetro controller and control pad. So RDWorks isn’t going to speak to that controller.

Updating firmware on these controllers can be dodgy. I suspect the problem is that 1. You don’t have the right software installed on the computer it’s trying to communicate to and 2. As you say, if the IT system has the user unable to use admin privileges or to write a temporary file locally to the computer, it will struggle to upload files to the cutter.

Frankly it should run on lasercut5.3 but remember you’ll need a dongle/softdog also.

One option for them would be to replace the controller and the key pad with Ruida controller (a fairly involved job). Maybe you should steer them towards me for a look?


1 Like

What Smokey said, have you got lasercut5.3 + dongle?

If that does not work then maybe you do need a new controller.

Let us know how it pans out!

1 Like

Yes I did say to them the next step is that I will speak to my Guy smokey and he will probably have to change the controller. I thought that might be the case.
I have tried my dongle on lasercut 5.3 but it doesn’t seem to communicate either.
I’ll let them know and maybe you’ll get a job out of them.
Thanks all

1 Like

Ok update number 3!.. I installed lasercut 5.3 and got the driver to be registered properly in the device manager. I’m still getting the error message “invalid config” on the controller panel so I’ve tried doing the download config but it just doesn’t do that trust beep and the panel shows nothing so I’m gonna guess this controller is done for and we need a new one? @Smokey is this something you could advise?

1 Like

It’s very likely that the controller is fried. It’s not 100% but from the info given and without going and running some test on it myself, that’d be my preferred conclusion.