How can I reset my Datum on Blacknose 40W


#1

Is there a way to reset the Datum on a Blacknose 40W from Just add Sharks?
The laser functions properly in all other respects and all settings for software etc seems in order.
I have found a way to turn the auto datum off in the settings but would like to be able to reset it… Why? … lengthy description here:

My datum function is out of alignment. If I start my laser it will try to auto datum but the location to which it tries to move the laser is beyond the area the laser head can be moved and thus makes it start grinding gears. I have not seen for how long does that as I immediately pressed stop the 2 times I tired.

I have been unable to find a tutorial explaining how.

How did I end up with this mildly annoying situation?
My best bet is this:
The first file I dowloaded to the laser was a copy of the included TEST file (cutting a measuring tool for the laser height). I simply made a copy of the file naming it TEST1 to see that it actually uploaded it as the laser display already showed the original TEST file.
That new file seems to have been corrupt in some way. When I tried to press test the laser moved at top speed first to low left corner and started grinding gears then a second later it moved back to upper right position and did the same - at this time ca. 3 seconds later i managed to regain my bearings and press stop.

Upon closer inspections the size of the copy was much smaller than the original one and all other files I have uploaded have worked fine.

But after this accident with the TEST1 file the auto datum has been out of alignment
I presume this is because the gears ( belts actually I guess) have been forced beyond their original position so the stepper motor has moved to Y ( forcing the belts over the gears) but the actual hardware it moves has been stopped dead by the cabinet at X.

SO: is there a way to simply position the laser head at the right place and then in the settings tell it that this will be the zero for the datum funciton?

All help is much appreciated!
Best wishes Johan Tieldow


#2

Sounds like one of your limit switches has stopped working or been knocked out of alignment. Do a physical inspection to see where they are and that they don’t look damaged, then you’re in to checking them with a meter.

Ian


#3

Ah! Limit switches :smiley: - I will take a look! Thanks!


#4

No worries.

Datum is set up each time you home so if it’s screwy that’s most likely the culprit. The Just add sharks lasers have nice limit switches so somethings probably just been knocked.

Ian.


#5

It may also be that you’ve incorrectly set the logical datum point. Follow the linked instruction.

Thanks


#6

Brilliant! - upon inspection both limit switches are in the right position and undamaged - the resetting of the logic org seems the right way to go and I have been meddling with the display a couple of times in order to figure out how it worked. Thanks!


#7

IT WORKS!!! the reset of the LogicOrg has made my Datum function fully functional! Thanks!


#8

Huzzah! :slight_smile: