Help.... Unit pulse calculation!

Hi all I need some help.

When I’m cutting 300mm on my x axis the cut is coming out as 305mm?? I know I need to change the pulse unit but when I change it to a smaller or larger number I still get the same.

Does anyone know how to work out what it should be by the stepper drivers and motors etc?

I’ve attached pics of my setting any help would be amazing!


I assume based on your user name, that the machine in question is a HPC LS1290, though it’s not clear from your post. You currently have the X axis “Range” set to 1000mm but your cutter is 1200mm is it not? You have the Y axis as 600mm, but again, I assume based on your user name that you have a 1200mm x 900mm machine? If you’re working on something else, please make it super clear.

The first thing I’d like to know is… what changed? Is this a new machine to you and you’re trying to set it up? Or was it all working okay then it changed itself?

Do you have the HPC’s Lasercut disk that would have come with the cutter? I should be able to look these settings up on another 1290 later today. Thanks.

Assuming your machine is a LS1290 (as per your user name) I had a look at the settings of a customers 1290 and below is a screen shot.

It is worth noting that the stepper drivers on your machine are

Leadshine 3ND583

and on the machine I took these settings from they are:
Leadshine DM442

let me know how you get on.

Hi and thank you for that.

No sorry it’s not a 1290. That is my other machine.

This one is another one we’ve just bought used. It is a 1000x600 bed.

I just can’t seem to get it right… even when I change the number down I still get bigger than the 300mm I need.

That’s why I was asking if there is a calculation to work it out

Ah, now I understand. What make and model is the cutter if you don’t mind me asking? I might be able to locate the original software or at least the settings.

if the motors and controllers are the same on both axis, then the pulse should be the same on both also. Do the dip switched on both match? Has one of the drivers been set differently? Note: don’t change the switches with the drivers powered up or you’ll overload the DC PSU.

What happens if you swap the connections on each stepper driver over, swap the X for the Y… do you still get an extra 5mm? If not, then the issue might be mechanical? I hope this helps.

It’s an old Redsail I think. Picture is attached.

Both the drivers have the same switches pressed up and down on them. And it’s getting extra distance on the y as well as the x axis.

I don’t have the original Cd hat came with it with the settings and I’m at my wits end trying to get this to work…

Would it be anything to do with the Pulse Unit Calculation box that pops up when you press “…” next to the pulse unit box?

That is set to Move 7.08000000 and Needs Pulse 1000.0

I don’t know what to put in there to get it to change anything?

You help is greatly appreciated by the way!!!

I’m sorry I can’t be more help. I’ve not had to calculate the values before, being able to use original software settings.

This link might help. I’ve been hunting around for an answer as I’m sure you have also.

Section 6.2 is about the work table and calculating the pulse unit. The info on the calculation is infuriatingly vague and badly translated.
“Move: When the stepping motor moves a circuit, the laser head will move a relative
length. You need to input the number in it.
Need pulse: The number is “driver’s subdivision number” ×200.”

I assume this means the length of one rotation. You might be able to find this info from the datasheet for the driver and the motor. Good luck… and if you DO solve it please let us know what you did.