Control panel error - Water Protector is Effective?

All if a sudden my laser control board (leetro) has come to with this error and I can’t do anything with my machine… it turns on then datums and then says water protector is effective??

The chiller is fine as it’s running water through the tube fine but I can’t seem to get rid of this error.

Has anyone had this before???

Hello @HPC1290
Well, I’ll be frank, I’ve not come across an error like this on the Leetro MPC6515 controller, in fact I didn’t know that the controller even had inputs for water protection (and I’ve not been able to find a pin-out that says it does, though I’ve not looked exhaustively).

On a HPC 1290 the flow sensor is on the right side behind a panel below the tube. It looks like this:


If you’ve had the cutter apart (say in half to move it or similar) this is a component that can be over looked at reconnection, though again, as mentioned, I’d expect this to send a signal to the high voltage PSU rather than the controller board.

I’ve also seen some HPC1290s with a bank of relays in the electronics bay on the left side AND with the controller board exposed to the elements. Check all this looks correct, no loose connections or shorts.

Other than the error message (I’d love a photo of it) does everything work as it should? Does the laser fire? Does your High Voltage PSU have an interlock/water protection LED that illuminates? Not all the laserscript PSUs have this.


Hi guys.

It’s not on our HPC machine it’s on a CTR one that we have just got. It’s still a Leetro controller.

The laser won’t fire or anything as that error is always on the control board. I keep pressing exit but Esc but it just beeps and then appears again?

If I have the machine turned off and then pull the gantry into the centre of the bed and turn the machine back on it goes through the datum process but then when the gantry is back to top left it beeps and give me this error again.

I’ve looked in the machine and there is no flow switch at all. The pipes go from the chiller to the connector pipes in the machine then from there straight to either end of the tube…? I’ve even tried another chiller that I had spare and still the same…

I have a video of that help but I can’t upload it…

Are you sure it’s a MPC6515? Can you take a photo of the controller in good light?

No sorry it’s a 6535